Pages

Saturday, 12 November 2016

Bronica battery trouble.

I really enjoy using my SQAi But recently its reliability has become unpredictable to the extent that I have seriously thought about getting rid of it.


I know what the problem is, it is to do with the silver oxide batteries and the way they make contact or not with the contacts in the camera. On occasions a film has built up insulating the batteries from the camera contacts. A quick scrape and all is well again. Recently this has gotten out of hand in such away that I'm no longer sure if the shutter will fire from one frame to the next even after checking that the contacts are clean.

I've concluded it is one of three things: the batteries are not up to the job, bad manufacture, or that something in the camera has worked loose? Or maybe all three. I am so fed up with it so much so that I have dug out my motor drive for the Bronica - something I have not used in years. I have also bunged on the eye level prism, which corrects the backward view you get from the flip up viewfinder. I did this because it makes the use of the camera more seamless.

A drastic move I know as Bronica did not produce an auxiliary battery pack for its cameras like others have. It adds weight that I'm not happy about but if it makes the camera more reliable then all to the good.


I can not believe how much these changes have reinvigorated my image making. It is akin to when I first purchased the camera. It works every time freeing me up from that nagging 'will it?' or 'wont it?'. It was satisfying to hear the clump of the shutter with the outlandish sound of the motor as it wound on. No more senior moments. With the addition of all this technical wizardry it has made it more enjoyable. If I had known this, I would have made the changes ages ago.

Has anyone else experienced this problem with their Bronica, if so how did you cure it?